首页 > Linux系统 > system > TP-LINK WR703N 刷OpenWrt教程
2012
12-06

TP-LINK WR703N 刷OpenWrt教程

1、下载安装
下载固件:

http://openwrt.googlecode.com/files/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin

进入路由器管理界面,出厂配置为http://192.168.1.1,用户名和密码均为admin,然后进入固件更新,选择下载的文件,然后更新。如下图所示
TP-LINK WR703N 刷OpenWrt教程 - 第1张  | 大博辞

TP-LINK WR703N 刷OpenWrt教程 - 第2张  | 大博辞

TP-LINK WR703N 刷OpenWrt教程 - 第3张  | 大博辞

TP-LINK WR703N 刷OpenWrt教程 - 第4张  | 大博辞

TP-LINK WR703N 刷OpenWrt教程 - 第5张  | 大博辞

等待一段时间(~~2min),然后重启路由。
P.S. 官方固件不带WebUI,所以需要对Linux系统较为熟悉,否则可以选择国内有人编译的带LuCI和中文支持的版本,Google即可。
2、初始配置
首先用一根网线将703N的Lan口和你电脑相连,电脑上设置为DHCP模式。然后运行cmd.exe
输入telent 192.168.1.1
成功后出现OpenWrt的欢迎界面:
TP-LINK WR703N 刷OpenWrt教程 - 第6张  | 大博辞

然后更改root密码:
输入passwd
更改root密码后dropbear(SSH 服务)就运行了,输入exit退出telent
以后就可以通过ssh管理OpenWrt
3、网络配置
OpenWrt官方的固件是不带LuCl的,所以初始的网络设定需要在命令行下完成
下载ssh连接工具putty
输入192.168.1.1
TP-LINK WR703N 刷OpenWrt教程 - 第7张  | 大博辞

点击open,如果弹出什么窗口点是即可
TP-LINK WR703N 刷OpenWrt教程 - 第8张  | 大博辞

输入用户名root回车 然后输入你刚刚设定的密码
然后用vi修改相关配置(不会用vim的同学悲剧了)。
首先修改/etc/config/wireless文件
输入vi /etc/config/wireless回车
TP-LINK WR703N 刷OpenWrt教程 - 第9张  | 大博辞

注释掉# option disabled 1
TP-LINK WR703N 刷OpenWrt教程 - 第10张  | 大博辞

进入此界面后按i进入修改模式,改成如图所示
改好后按esc,然后输入:wq保存退出
然后修改/etc/config/network文件。
首先修改lan接口配置,注释掉此行:

# option ifname 'eth0'

然后增加wan接口,如果你上级网络是DHCP的,则文件的末尾添加:

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'

如果你上级网络是静态IP,则在文件的末尾添加:

config interface 'wan'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '10.22.33.124'
    option netmask '255.255.255.0'
    option gateway '10.22.33.1'
    option dns '202.113.16.10'

TP-LINK WR703N 刷OpenWrt教程 - 第11张  | 大博辞
此图为修改为静态ip模式
然后将路由器的Lan/Wan口接到上级网络中,重启路由器。
这时便可以通过电脑寻找SSID为 OpenWrt的无线网络,加入后电脑便可以通过703N上网了。
接着ssh 到路由器
登陆后输入

opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

就有luci(WEB)界面了~
完后就可以通过浏览器访问192.168.1.1来配置路由器了
这样就可以玩你的WR703N了
未完,待续

最后编辑:
作者:admin
捐 赠如果您觉得这篇文章有用处,请支持作者!鼓励作者写出更好更多的文章!

留下一个回复